Не стартует служба apache после обновления PHP

ehndrju
Сообщения: 2
Зарегистрирован: 07 апр 2012
Здравствуйте.
Скачал, установил AppServ 2.5.10
Все работает отлично. Пытаюсь обновить PHP до версии php-5.3.9-Win32-VC9-x86 по инструкции в теме на форуме. (т.е. остановка службы, распаковка архива в папку php5, запуск службы) и тут служба не хочет стартовать ((
Подскажите что не так делаю ((

В журнале событий такая штука:
-----------------------------------------------------------------
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 205 of C:/AppServ/Apache2.2/conf/httpd.conf: Cannot load C:/AppServ/php5/php5apache2_2.dll into server: \xcf\xf0\xe8\xeb\xee\xe6\xe5\xed\xe8\xe5 \xed\xe5 \xe1\xfb\xeb\xee \xe7\xe0\xef\xf3\xf9\xe5\xed\xee, \xef\xee\xf1\xea\x.

Аватара пользователя
Distructor
Администратор
Сообщения: 1631
Зарегистрирован: 28 дек 2009
Начиная с PHP 5.3.6 перестали делать сборки под старую версию Apache
(см. viewtopic.php?p=6277#p6277 спойлер "Пользователям Windows").

Соответственно тебе либо обновить Apache, либо обновлять PHP только до 5.3.5.


P.S. добавил информацию об этой проблеме в тему по обновлению AppServ viewtopic.php?t=197
Последний раз редактировалось Distructor 09 апр 2012, 11:14, всего редактировалось 1 раз.
Причина: исправлен номер версии

ehndrju
Сообщения: 2
Зарегистрирован: 07 апр 2012
Спасибо!!!

-- добавлено 08 апр 2012, 10:38 --

Но у меня опять все не слава богу ))
Сперва скачал архив php-5.3.6-Win32-VC9-x86.zip попробовал его распаковать, но служба опять не стартанула. откатился все назад. взял php-5.3.6-nts-Win32-VC9-x86.zip и служба стартанула. но почему то phpinfo(); выдает мне: PHP Version 5.2.6 ((

Аватара пользователя
Distructor
Администратор
Сообщения: 1631
Зарегистрирован: 28 дек 2009
тебе нужны версии VC6, а не VC9.

получается что я немного ошибся - последняя версия поддерживающая старый апач PHP 5.3.5

p.s. исправил свое прошлое сообщение


Вернуться в «Вопросы по веб-серверам»