Ошибка : invalid info_hash

Аватара пользователя
Евгений
Сообщения: 215
Зарегистрирован: 01 янв 2010
Ребята помогите не могу как с этим бороться?
Стоит версия R325 TP.
На трекере через раздачу пишет вот эту вот ошибку в utorrent'e - invalid info_hash (((
Раздача всё хорошо , потом плохо, не пойму.
смена типа поля info_hash с char(20) на varbinary(20) решило проблему :-)

Сделал.
Не помогло(((
Нужна помощь.

-- добавлено 23 окт 2010, 20:26 --

ау ребята не кто не знает?
Где курить хуть скажите по пробую по возиться.
Это в кодировке дело / или в некорректном обращение клиента к сайту? какие могу быть варианты?
Просто в БД смущает меня поля info_hash:

Код: Выделить всё

уpе+—вx:БqUгЅ±ї,
Кто не работает - тот школота©

Аватара пользователя
Distructor
Администратор
Сообщения: 1599
Зарегистрирован: 28 дек 2009
какая кодировка у этого поля и какая у всех остальных текстовых полей?

Аватара пользователя
Евгений
Сообщения: 215
Зарегистрирован: 01 янв 2010
Сравнение utf8_bin поставил и на cp1251 тоже самое:
Вложения
1.JPG
Кто не работает - тот школота©

Аватара пользователя
Distructor
Администратор
Сообщения: 1599
Зарегистрирован: 28 дек 2009
добавь скрин структуры таблицы (без данных только описание самой таблицы)

Аватара пользователя
Евгений
Сообщения: 215
Зарегистрирован: 01 янв 2010
это?
1.JPG


-- добавлено 24 окт 2010, 16:05 --

Код: Выделить всё

CREATE TABLE IF NOT EXISTS `bb_bt_torrents` (
  `info_hash` char(20) character set utf8 collate utf8_bin NOT NULL,
  `post_id` mediumint(8) unsigned NOT NULL default '0',
  `poster_id` mediumint(9) NOT NULL default '0',
  `topic_id` mediumint(8) unsigned NOT NULL default '0',
  `forum_id` smallint(5) unsigned NOT NULL default '0',
  `attach_id` mediumint(8) unsigned NOT NULL default '0',
  `size` bigint(20) unsigned NOT NULL default '0',
  `reg_time` int(11) NOT NULL default '0',
  `call_seed_time` int(11) NOT NULL default '0',
  `complete_count` mediumint(8) unsigned NOT NULL default '0',
  `seeder_last_seen` int(11) NOT NULL default '0',
  `tor_status` tinyint(4) NOT NULL default '0',
  `checked_user_id` mediumint(8) NOT NULL default '0',
  `checked_time` int(11) NOT NULL default '0',
  `tor_type` tinyint(1) NOT NULL default '0',
  PRIMARY KEY  (`info_hash`),
  UNIQUE KEY `post_id` (`post_id`),
  UNIQUE KEY `topic_id` (`topic_id`),
  UNIQUE KEY `attach_id` (`attach_id`),
  KEY `reg_time` (`reg_time`),
  KEY `forum_id` (`forum_id`),
  KEY `poster_id` (`poster_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8;
Кто не работает - тот школота©

Аватара пользователя
Distructor
Администратор
Сообщения: 1599
Зарегистрирован: 28 дек 2009
мдэ..
придется смотреть код - в какой кодировке, что и когда пишется в таблицу, т.к. значения в info_hash действительно давольно странные..

p.s. я в ближайшее время занят и развернуть движок у себя чтобы его поковырять пока не смогу

Аватара пользователя
Евгений
Сообщения: 215
Зарегистрирован: 01 янв 2010
Distructor
ок потом вообще с раздачами какой то бред (((
что делать не знаю.
Что чё я тебе в БД и ftp акк даже дам)
Только ошибку подробнее опиши что где и как делать, на ошибках учатся)
Кто не работает - тот школота©


Вернуться в «Вопросы по движкам/скриптам»